Go Back   Club Bazooka > Search Forums

Notices

Showing results 1 to 25 of 500
Search took 0.05 seconds.
Search: Posts Made By: heavyduty
Forum: Amplified Tube Subwoofers 10-04-2017, 07:51 AM
Replies: 1
Views: 76
Posted By heavyduty
Re: Fried nos8 amp

Give Technical Support a call at 1-800-THE-TUBE.
Forum: Amplified Tube Subwoofers 09-26-2017, 08:10 AM
Replies: 9
Views: 141
Posted By heavyduty
Re: Bazooka BTA10100 not working correctly please help!

You can use the rear speakers or the front speakers for the High Level Input Signal. I would use the larger speakers of the two. This can be done at the speakers or at the harness. Do you have a...
Forum: Amplified Tube Subwoofers 09-25-2017, 03:45 PM
Replies: 220
Views: 100,058
Posted By heavyduty
Re: FAST-9999 Installaton Instructions

You only need to tap two wires, plug in the RCA's, and connect to a proper ground.
Forum: Amplified Tube Subwoofers 09-25-2017, 02:55 PM
Replies: 220
Views: 100,058
Posted By heavyduty
Re: FAST-9999 Installaton Instructions

Then use the RCA's for the signal input, and connect the constant +12v to the constant +12v of the headunit/harness, the switched +12v to the key-on/key-off source at the harness and of course the...
Forum: Amplified Tube Subwoofers 09-25-2017, 02:42 PM
Replies: 220
Views: 100,058
Posted By heavyduty
Re: FAST-9999 Installaton Instructions

Not a dumb question at all. You can connect anywhere in the harness, as they are all going to the speakers. For the best performance, connect to the front speakers. Unless they are of an extremely...
Forum: Amplified Tube Subwoofers 09-25-2017, 08:56 AM
Replies: 9
Views: 141
Posted By heavyduty
Re: Bazooka BTA10100 not working correctly please help!

Thanks for posting the picture. Unfortunately I could not see enough of the ground you were referring to. Be sure to read my response to your previous post, this will allow us to determine if the...
Forum: Amplified Tube Subwoofers 09-25-2017, 08:54 AM
Replies: 9
Views: 141
Posted By heavyduty
Re: Bazooka BTA10100 not working correctly please help!

Grab your DMM, and measure the voltage of the output leads. If the amplifier is working, you will see voltage at the terminals. If there is no voltage, the amplifier is not working.
Forum: Amplified Tube Subwoofers 09-23-2017, 08:25 PM
Replies: 9
Views: 141
Posted By heavyduty
Re: Bazooka BTA10100 not working correctly please help!

Just curious as to why you did not tap into the factory harness after the amp? I would remove the back plate or the driver and check to make sure that one of the speaker connections has not come...
Forum: Amplified Tube Subwoofers 09-23-2017, 07:34 PM
Replies: 9
Views: 141
Posted By heavyduty
Re: Bazooka BTA10100 not working correctly please help!

The end plates for the BTA10100 and the BTA10250 are different. As for the problem you are experiencing, do you have any output from the rest of the factory stereo?

What happens if you unplug the...
Forum: Marine Audio 09-12-2017, 07:58 AM
Replies: 5
Views: 157
Posted By heavyduty
Re: Marine Tubbies Muffled 8"

It could have been a clipping issue of the amplifier, DC voltage will kill a voice coil. Or, the voice coil lost alignment. It happens. Give Customer Service a call and ask about a replacement. ...
Forum: Marine Audio 09-11-2017, 10:12 AM
Replies: 5
Views: 157
Posted By heavyduty
Re: Marine Tubbies Muffled 8"

Yes, if the voice coil is bad, or is out of alignment, any movement of the cone, powered or passively, will result in noise. As for the front 6.5", does this speaker make noise at all volumes?
Forum: Marine Audio 09-09-2017, 12:45 PM
Replies: 5
Views: 157
Posted By heavyduty
Re: Marine Tubbies Muffled 8"

Sounds like a voice coil has gone bad. Call 1-800-THE-TUBE, on Monday to discuss the appropriate remedies. Just keep in mind, Irma may have other plans, so if you do not get an answer, don't forget...
Forum: Amplified Tube Subwoofers 09-08-2017, 10:21 AM
Replies: 1
Views: 92
Posted By heavyduty
Re: RCA Inputs

Yes, you do need both of the RCA jacks. Trace the patch cord back to the source, to make certain you do not have one unplugged. Also, have you tried switching out patch cords?
Forum: General Chat 08-23-2017, 11:50 AM
Replies: 5
Views: 288
Posted By heavyduty
Re: Old school VS new amplified

If you have the room, I say purchase the salve unit. It will be an upgrade from you existing pair of 8" Tubes. Another great bonus with the 250D, it will perform flawlessly at 2 ohm's mono.
Forum: General Chat 08-22-2017, 10:22 AM
Replies: 5
Views: 288
Posted By heavyduty
Re: Old school VS new amplified

Yes, use your existing RCA's, constant +12v, remote turn-on and ground connections, and connect to the BTA10250D. Don't forget to purchase your BT1014, and get ready to drop some wicked low's.
Forum: General Chat 08-21-2017, 01:19 PM
Replies: 5
Views: 288
Posted By heavyduty
Re: Old school VS new amplified

If you have the room, go with the 10" BTA10250D. There is no replacement for displacement.
Forum: Hook me up! 08-21-2017, 01:18 PM
Replies: 1
Views: 236
Posted By heavyduty
Re: Powered Bazooka Tube (NOS8)

Yes, your son has purchased a passive NOS8. The red and blue wires are the speaker wires, and these colors are used to keep with the NOS scheme. You can use the red for the positive terminal...
Forum: Amplified Tube Subwoofers 08-02-2017, 12:41 PM
Replies: 20
Views: 692
Posted By heavyduty
Re: BTA10200 - did i break it?

The back plates should bolt right into place. Give Cathy a call, (1-800-THE-TUBE), and explain the situation, that the A200 amp is dead and you would like to upgrade, there may be a trade-in credit....
Forum: Amplified Tube Subwoofers 08-02-2017, 10:46 AM
Replies: 20
Views: 692
Posted By heavyduty
Re: BTA10200 - did i break it?

You have absolutely exhausted every possibility. Yes, you can remove the amplifier from the Tube and take a look at the board, as well as the components. It could be a minor component that needs to...
Forum: Amplified Tube Subwoofers 08-01-2017, 05:15 PM
Replies: 20
Views: 692
Posted By heavyduty
Re: BTA10200 - did i break it?

Yes. Just connect the constant +12V and the orange remote wire together. Let's make sure you have a good switched source.
Forum: Amplified Tube Subwoofers 08-01-2017, 03:27 PM
Replies: 20
Views: 692
Posted By heavyduty
Re: BTA10200 - did i break it?

It's a step by step process in troubleshooting. Try this, remove the remote wire from where you have it connected now, and connect it directly to the +12v positive of the Tube.
Forum: Amplified Tube Subwoofers 08-01-2017, 02:53 PM
Replies: 20
Views: 692
Posted By heavyduty
Re: BTA10200 - did i break it?

Did you take the fuses out and check them with a DMM? I have seen plenty of fuses that visually look great, but have an open circuit, because they have blown where you cannot see the break in the...
Forum: Amplified Tube Subwoofers 07-31-2017, 03:36 PM
Replies: 20
Views: 692
Posted By heavyduty
Re: BTA10200 - did i break it?

I was able to see your post. How did you check your fuses? Visually or with a DMM?
Forum: Amplified Tube Subwoofers 07-30-2017, 12:45 PM
Replies: 20
Views: 692
Posted By heavyduty
Re: BTA10200 - did i break it?

No, the two parts are completely different. The 250D brought back the Slave Unit option. The connectors being used do look interchangeable, I will give you that. However, using the wrong connector...
Forum: Passive Tube Subwoofers 07-30-2017, 12:35 PM
Replies: 2
Views: 402
Posted By heavyduty
Re: 12 inch dvc bazooka tube

What is the power output of your amplifier? Are you going to use the DVC model and drive a 2 ohm mono load?
Showing results 1 to 25 of 500

 
Forum Jump

All times are GMT -5. The time now is 11:52 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
bazooka.com
SAS, BAZOOKA, BASS TUBES, and LISTEN TO YOUR EARS are registered trademarks of Southern Audio Services, Inc.